APC – Alternative PHP Cache

J’ai récemment étudié les problématiques de cache pour accélérer l’affichage des pages servies par des CMS PHP.
J’ai décidé d’installer APC.
Je ne vais pas rentrer dans le détail, car si ça vous intéresse, vous savez où trouver les informations précises que je ne prendrai pas la responsabilité de vulgariser ici.
Je précise juste qu’APC fera partie du coeur de PHP6, et c’est une des raisons pour laquelle je l’ai privilégié par rapport à d’autres accélérateurs PHP.

L’acronyme APC est très populaire. Je parle ici de l’Alternative PHP Cache.

Voici comment j’ai procédé pour l’installer.

Sous Debian (j’ai testé la configuration d’APC sous Lenny) il faut s’assurer d’avoir installé les packages php-pear et php5-dev.
Ensuite vous n’aurez qu’à lancer la commande :

#  pecl install apc

Ensuite il vous faudra créer le fichier /etc/php5/apache2/conf.d/apc.ini et ajouter dedans :

extension=apc.so

Sous Freebsd 7, après avoir vérifié que pear était bien installé, j’ai également lancé :

# pecl install apc

Puis j’ai ajouté une ligne contenant extension=apc.so dans /usr/local/etc/php/extensions.ini.

En réalisant des benchmarks avec ab j’ai constaté d’énormes gains de temps pour l’affichage de 1000 pages générées par WordPress.
-87% avec sur un serveur OVH kimsufi tournant sous Debian 5.01 en 64bits et -68% sur un serveur OVH kimsufi tournant sous Freebsd 7.0 en 32 bits.

En moyenne le temps de génération de la page d’accueil de ce blog a été diminué par deux depuis que j’ai installé APC sur le serveur qui l’héberge.

2 Commentaires

  1. paradize
    Posté le 10 juin 2009 à 19:45 | Permalink

    Ca fait 1 mois environ que j’ai safari qui traîne, qui traîne, qui traîîîîîîîîne…

    Des fois, je force à quitter pour pouvoir repartir sur de bonnes bases.

    Est ce que je dois faire qqchose de spécial, tu crois ???

    :-S

  2. snoop
    Posté le 10 juillet 2009 à 13:23 | Permalink

    Pour info si vous avez la même erreur que moi :

    configure: error: Aborting
    ERROR: `/tmp/pear/temp/APC/configure –with-apxs’ failed

    Il suffit d’installer le paquet : apache2-threaded-dev

Soumettre un commentaire

Vous devez être connecté pour laisser un commentaire.